Post Particle Effects

The previous post processing tutorials introduced some post image effects, which examine and modify the image rendered by the ray tracer.

The program also includes another category of post effects: so called post particle effects. They also draw their effect to a post image during post processing. The characteristic property of post particle effects is that they use geometric objects (particles) to define the position of effects in 3d space. The following comparison illuminates the difference between the two effect categories:

Mapping effects to particles

You can define the appearance of post particles using particle effects just like you define the appearance of ordinary geometric objects using materials: by mapping effects to particles. The idea is that particle objects define geometric properties such as position, size and orientation. The mapped effect uses the geometry information when rendering a shape representing the particle. The following example, a flock of lens flares, demonstrates this.

Tutorial level: Beginner

1. Create a bunch of 1D particles using the particle tool. Activate the tool from the Creation tab of the toolbar and drag the mouse around the view (left mouse button held down). Click the Accept button to finish the particle tool.

Particle tool activated

2. Render the view. You can see the particles as small dots. However, there is no post processing going on yet - what you see is scanline particle rendering.

Particle object selected

3. Make sure that the particle object is selected. Open the property window from the Object Properties.. entry of the view popup menu, go to the Spec tab and clear the Scan Line option. Now the particles will be rendered using post processing system only. As a matter of fact, some post effects are sensitive to object distances, and leaving scanline drawing enabled may disturb post particle drawing later (post particles become hidden by scanline particles). Close the property window.

Scanline rendering disabled
Particle Effects

4. Go to the Post Particle Effects tab of the select window and drag&drop the desired particle effect into the view window. This maps the effect to the selected object (=particles).

5. You have now created a flock of 'lens flare' particles. Go to the object hierarchy tab in the select window, and open the sub hierarchy of the new object level '1D particle+default mapping(Lensflare)'. The hierarchy should look something like in the example image:

Note how object hierarchy is used exactly the same way as in material mapping (a wooden candlestick consists of the candlestick and wood mapping).

'Lens flare particles' object consists of two sub objects: 1D particles and a lens flare effect
The effect configuration contains the module for rendering post particles

6. Everything should now be ready for rendering the flares. However, let us check one important setting before rendering. Go to the Post Image Effects tab of the select window. To make sure that we are using the right post processing configuration, drag & drop the Default Effects item to the view window. It is used by the standard startup project, but you may have changed the configuration when experimenting with previous post image effect tutorials. Then double click Default Effects to open the property window. The window shows the contents of the selected post image.

There is one particularly interesting item included in the list of active effects: Render particle effects. It must be included or otherwise post particles will not be rendered. By changing the position of this object in the list, you can define when the post particle effect rendering takes place. The configuration is suitable, so close the property window without changes.

7. Click the ray trace button in the view control bar (or select the view's popup menu Render/Ray trace).

A flock of lens flares

Using multiple effects

Let's assume you want to create two particle flocks: one whose particles are rendered with a 'star' effect and another one, which is rendered with a 'red rings' effect. To do this:

1. Activate the particle tool and create a number of 1D particles. When done, select Accept from the view's popup menu.

2. Activate the particle tool again and created the second particle object. The two particle objects might look as in the example image.

3. Select the first 'stars' particle object and drag and drop the 'star' effect from the select window's Post Particle Effects tab into the view window.

4. Select the second 'ring' particle object and drag & drop the 'red rings' effect into the view window. The current object hierarchy is shown on the right.

Two particle objects with different effects

5. Start rendering.

[Note] Note
You can combine effects by mapping multiple effects to a single object. The order of mapping objects in the hierarchy defines the order the effect are rendered.

Creating new particle effects

New particle effects can be created from the popup menu in the Select window's Post Particle Effects tab. The New sub-menu shows you the installed post effects. Just select an entry to create a new effect and use the property window to define its attributes as usual.

Note that one effect, such as the Lens Flare, can render a large number of different kinds of effects, from simple stars and rings to complex lens flares.